Сейчас просматривают тему: 0 -> --, и гостей: 1

Cloudflare как динамический DNS на Mikrotik

Ссылка на пост #1 Добавлено: 28 ноября 2014 11:12
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 33 Водолей
Пол:
С нами: 9 лет 1 месяц
Сообщений: 6380
Поблагодарил: 5501
Благодарностей: 20278
Предупреждений: 0

Награды:

     

Есть чудесный бесплатный сервис Cloudflare, который позволяет прятать свой реальный ip при использовании доменных имен. Быстро изменяет записи на всех доменных именах и за деньги может даже отфильтровать трафик от флуда и прочей грязи (но это уже другая история, скажем дорогая и не удобная история)

Сразу привожу полный скрипт, а нижу будет разбор полётов.

Код:[Выделить]
######## Set and collect general variables ######### :global hostname "soft.hd.zp.ua" :global resolvedIP "" :global externalIP "" :global WANInterface "ISP1" ######## Set CloudFlare variables ################# :local CFemail "mail@hd.zp.ua" :local CFtkn "3c8b585915544145becded4f2b58068177a33" :local CFzone "hd.zp.ua" :local CFid "178055949" :local CFtype "A" :local CFttl "1" :local CFservicemode "0" :local CFDomain "soft" :local CFDebug "true" ######## Resolve and set IP-variables ########## /ip DNS cache flush :local currentIP [/ip address get [/ip address find interface="ISP1" ] address]; :set externalIP [:pick $currentIP 0 [:find $currentIP "/"]]; :set resolvedIP [:resolve $hostname]; ######## Build CF API Url ######################### :local CFurl "https://www.cloudflare.com/api_json.html\3F" :set CFurl ($CFurl . "a=rec_edit&tkn=$CFtkn&id=$CFid"); :set CFurl ($CFurl . "&email=$CFemail&z=$CFzone&type=$CFtype"); :set CFurl ($CFurl . "&name=$CFDomain&service_mode=$CFservicemode&ttl=$CFttl"); ######## Write debug info to log ################# :if ($CFDebug = "true") do={ :log info ("CF: hostname = $hostname") :log info ("CF: resolvedIP = $resolvedIP") :log info ("CF: currentIP = $currentIP") :log info ("CF: externalIP = $externalIP") :log info ("CF: CFurl = $CFurl&content=$externalIP") }; ######## Compare and update CF if necessary ##### :if ($resolvedIP != $externalIP) do={ :log info ("CF: Updating CF, setting $CFDomain = $externalIP") /tool fetch mode=https url="$CFurl&content=$externalIP" keep-result=no /ip DNS cache flush } else={ :log info "CF: No Update Needed!" }


:global hostname “soft.hd.zp.ua” – это полный адрес поддомена
:global WANInterface “ISP1″ – интерфейс Mikrotik с динамическим IP который смотрит в интернет
:local CFemail “mail@hd.zp.ua” – почта Вашей учётной записи на Cloudflare
:local CFtkn “3c8b585915544145becded4f2b58068177a33″ – это секретный ключик Вашей учётки на Cloudflare, взять можно тут Account – My account – Your API key is: 3c8b585915544145becded4f2b58068177a33
:local CFzone “hd.zp.ua” – Ваш домен
:local CFid “178455949″ – это ключ домена, как получить чуть ниже
:local CFtype “A” – тип записи
:local CFttl “1″
:local CFservicemode “0″ – скрывать или нет ip адрес, если скрывать, поставить “1″
:local CFDomain “soft” – имя субдомена
:local CFDebug “true” – дебажим или нет

И так, как получить :local CFid для определенного субдомена
Для этого нужен любой сервер под Linux
Заходим через ssh или telnet на сервер и даём команду
curl https://www.cloudflare.com/api_json.html -d 'a=rec_load_all' -d 'tkn=3c8b585915544145becded4f2b58068177a33' -d 'email=mail@hd.zp.ua' -d 'z=hd.zp.ua'
Опять же:
tkn=3c8b585915544145becded4f2b58068177a33 – наш ключик от учётки
email=mail@hd.zp.ua – email учётной записи
z=hd.zp.ua – наш домен

Получим в ответ многабукаф по всем записям домена hd.zp.ua
Нам необходимо найти rec_id”:”178455949″ принадлежащий субдомену soft.hd.zp.ua

Добавляем скрипт в System – Scripts , например с именем cloudflare soft.hd.zp.ua
После чего добавляем в System – Scheduler задание с именем cloudflare soft.hd.zp.ua и выбираем желаемый интервал выполнения.

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 1 : kolobokru
Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    «Триколор ТВ» и Mezzo: эффективная реализация международных принципов пакетирования

    «Триколор ТВ» и телеканал Mezzo организуют прямую трансляцию исполнения мирового шедевра

    Новый виток развития телевидения — дроны

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» совместно с НП «ГЛОНАСС» и телеканалом Life запускает федеральный проект «Россия глазами дронов»

    Индустрия дронов — будущее России

    1 декабря 2016 года на пресс-конференции по Кубку чемпионов по дрон-рейсингу в рамках «Транспортной недели-2016» помощник Президента России Игорь Левитин, заместитель министра транспорта Алексей Цыденов, президент НП «ГЛОНАСС» Александр Гурко и генеральный директор «Триколор ТВ» Алексей Холодов обсудят перспективы развития отрасли беспилотных авиационных систем (БАС) в России и их применение в телекоммуникационной отрасли

    «Триколор ТВ» признан самым инновационным оператором Европы

    25 ноября 2016 года российский оператор цифрового телевидения «Триколор ТВ» единственный из европейских операторов стал обладателем премии за внедрение инновационных сервисов и технологий в рамках международной премии Eutelsat TV Awards

    «Триколор ТВ» принял участие на RIW–2016

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» впервые принял участие на Russian Interactive Week

    Конкурс детской новогодней открытки

    В преддверии Нового года Телекарта и Канал Disney представляют конкурс детской новогодней открытки!

    Абоненты Телекарты получают «Приоритет»

    «Приоритет» – это комплексная услуга для абонентов «Телекарты», предоставляющая своим пользователям право на эксклюзивное обслуживания, уникальные услуги и предложения.

    «Премия Рунета» досталась «Телекарте Онлайн»

    SMART TV ОТ «ТЕЛЕКАРТЫ» ТЕПЕРЬ В LG!

    Как мы и обещали, линейка «умных» телевизоров, на которых доступна «Телекарта Онлайн» пополнилась модельным рядом телевизоров LG!

    TOPSONG TV и DANGE TV меняют название

    TOPSONG TV и DANGE TV меняют название

Телепрограмма

СТБ
08:15 - Х/ф "Молодая жена".
10:10 - Т/с "Я не вернусь", 1-4 с.
13:20 - Т/с "Я не вернусь", 5-9 с.
18:00 - "Викна-Новости".
Футбол 1
08:15 - Барселона - Боруссия Менхенгладбах. Лига чемпионов.
10:00 - Футбол News. Live.
10:25 - Зальцбург - Шальке 04. Лига Европы.
12:10 - Реал Мадрид - Боруссия Дортмунд. Лига чемпионов.
ICTV
09:15 - Чрезвычайные новости.
09:55 - Х/ф "Паршивые овцы", 1 и 2 с.
12:05 - Х/ф "Черный дождь", 1 ч.
12:45 - Факты. День.
Кинопремьера HD
09:15 - Х/ф "Любовь и дружба".
10:55 - Х/ф "Вторая жизнь Уве".
12:50 - Х/ф "Родина".
14:45 - Х/ф "Принц".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Вернетесь ли вы на этот сайт снова?

Да
Нет
Затрудняюсь ответить

Случайное фото

Sat-integral club

ПО Sat-Integral S-1225 HD Able версии 2.05 Beta

Цитата: Svoyak от Вчера в 21:42:08Хтось уже протестив цю ПО??? обновил жене на кухне,пока жалоб не ...

Продление Funcam

Цитата: Павел от 07 Декабрь 2016, 14:14:35я то понимаю,что  работает на ура пробуй двигать ...

Продление G-share

Цитата: Qarts60 от 07 Декабрь 2016, 22:47:47Кто продлевал сразу два серийника подскажите Вопрос ...

ПО Sat-Integral S-1225 HD Able версии 2.05 Beta

Цитата: sat-integral от Вчера в 17:48:26ПО Sat-Integral S-1225 HD Able версии 2.05 BetaХтось уже ...

Натройка платного шаринга на SI1226k3

Цитата: Rust6 от Вчера в 21:26:32посоветуйте сразу недорогого украинского шародателя на НТВ+пиши в ...

Установка MySQL 5.6 на Centos 6

Будем использовать ...