Сейчас просматривают тему: 0 -> --, и гостей: 1

no-ip.org как динамический DNS на Mikrotik

Ссылка на пост #1 Добавлено: 28 ноября 2014 11:16
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 34 Водолей
Пол:
С нами: 9 лет 10 месяцев
Сообщений: 6695
Поблагодарил: 5722
Благодарностей: 21763
Предупреждений: 0

Награды:

      

Сервис динамического обновления ip адреса для Ваших доменов от no-ip.org
Сразу предупреждаю что этот сервис для бесплатной работы, будет засыпать Вас письмами для продления. Не нажали на ссылку, перестанет работать.

И так сам скрипт:

Код:[Выделить]
:local ddnsuser "mail@hd.zp.ua" :local ddnspass "PASS" :local ddnshostname "satsis.no-ip.org" :local ddnsinterface "ISP2" :global ddnslastip [:resolve $ddnshostname]; :global ddnsip [ /ip address get [find interface="ISP2"] address ] :if ([ :typeof $ddnsip ] = "nil" ) do={ :log info ("ServiceDNS: No ip address on $ddnsinterface .") } else={ :for i from=( [:len $ddnsip] - 1) to=0 do={ :if ( [:pick $ddnsip $i] = "/") do={ :set ddnsip [:pick $ddnsip 0 $i]; } } :if ($ddnsip!=$ddnslastip) do={ :log info ("ServiceDNS: $ddnshostname -> $ddnsip") :global str "/nic/update?hostname=$ddnshostname&myip=$ddnsip" /tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname) :global ddnslastip $ddnsip } }


:local ddnsuser “mail@hd.zp.ua” - почта учётной записи
:local ddnspass “pass” - пароль учётной записи
:local ddnshostname “satsis.no-ip.org” – Ваш домен
:local ddnsinterface “ISP2″ – интерфейс с динамическим ip
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 3 : kolobokru, valdis123, Mig777
Реклама
Ссылка на пост #2 Добавлено: 1 декабря 2014 14:30
 
Полное имя: Андрей
Группа: Посетители
Азъ: помогу любому
Возраст: 43 Рыбы
Пол:
С нами: 8 лет 3 месяцa
Сообщений: 883
Поблагодарил: 193
Благодарностей: 1314
Предупреждений: 0

Награды:

   

А не проще ли использовать встроенный в RouterOS сервис Cloud, который сам назначит роутеру имя на DDNS сервере и будет сам следить за изменением IP?

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: Vu+ Zero, GoldenMedia 990 SR

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 1 : Mig777
Ссылка на пост #3 Добавлено: 1 декабря 2014 15:43
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 34 Водолей
Пол:
С нами: 9 лет 10 месяцев
Сообщений: 6695
Поблагодарил: 5722
Благодарностей: 21763
Предупреждений: 0

Награды:

      

Цитата: zmej74
А не проще ли использовать встроенный в RouterOS сервис Cloud, который сам назначит роутеру имя на DDNS сервере и будет сам следить за изменением IP?


А сами пробовали?
Я вообще стараюсь такие сервисы обходить стороной по 2м причинам:
1. Активируя его, Вы сами соглашаетесь дать доступ облаку к вашему тику. Порт никак не контролируется и может использоваться как угодно, хоть для активации DDOS атак с вашего оборудования.
2. Скорее всего есть какой-то публичный сервис где Ваш тик будет светить синим светом, маня всевозможных кулхацкеров в гости.

+ ко всему скриптом выше можно самостоятельно назначать домен который хотите, можно делать интервал времени проверки.
Да и никто не заставляет что-то самому писать
вставил скрипт, поменял значения на свои и используй.
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 1 : Mig777
Реклама
Ссылка на пост #4 Добавлено: 2 декабря 2014 08:57
 
Полное имя: Андрей
Группа: Посетители
Азъ: помогу любому
Возраст: 43 Рыбы
Пол:
С нами: 8 лет 3 месяцa
Сообщений: 883
Поблагодарил: 193
Благодарностей: 1314
Предупреждений: 0

Награды:

   

А сами пробовали?

конечно пробовал! Этот сервис создает на Микротиковском сервере учетку так же как и на no-ip. Только учетка не очень удобочитаемая.
Ну и не нужно выполнять операции по регистрации имени - все сделает роутер. И дальше будет синхронизировать адрес IP. В принципе, будет делать то же что и твой скрипт - только автоматом.
А на работе я использую белый статический IP. Ибо, по-моему, брать такой аппарат и сэкономить на IP...
Активируя его, Вы сами соглашаетесь дать доступ облаку к вашему тику. Порт никак не контролируется и может использоваться как угодно, хоть для активации DDOS атак с вашего оборудования

Совсем наоборот - тик получает доступ к DDNS серверу. Если уж так заботиться о безопасности - где гарантия что:
1. бесплатные DDNS сервера (no-ip) не сливают свои базы и не организовывают DDOS атаки?
2. в самой прошивке роутера не встроено шпионское ПО, которое потихоньку стучит и принимает команды из вне.

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: Vu+ Zero, GoldenMedia 990 SR

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 3 : sealv, maxya, Mig777
Ссылка на пост #5 Добавлено: 2 декабря 2014 22:14
 
Полное имя: Владимир
Группа: Друзья satsis.info
Азъ: интересующийся
Возраст: 31 Дева
Пол:
С нами: 4 года 11 месяцев
Сообщений: 28
Поблагодарил: 20
Благодарностей: 52
Предупреждений: 0

Репутация:

Награды:

 

Цитата: zmej74
Ну и не нужно выполнять операции по регистрации имени


В этой ветке есть скрипт для Cloudflare, там не нужно активировать домен как no-ip каждый месяц. Там один раз и на долго. Количество доменов не ограничено!

Цитата: zmej74
В принципе, будет делать то же что и твой скрипт - только автоматом.


Ну суть вопроса наверное еще во времени выполнения смены ip, скриптом вы сами определяете интервал. Ну + ко всему, как я понял. Динамически еще обновляется проброс портов и маршруты.

Цитата: zmej74
А на работе я использую белый статический IP. Ибо, по-моему, брать такой аппарат и сэкономить на IP...

Ну на работе то понятно, а платить например киевстару 35 грн за белый ip как по мне не резонно. Особенно если тариф на интернет 70-80 грн. Закинул скрипт и Живи спокойно.

Цитата: zmej74
1. бесплатные DDNS сервера (no-ip) не сливают свои базы и не организовывают DDOS атаки?

Суть вопроса не в том даже что сливают, а в том что вы по сути ставя галочку в этом пункте роутера, добровольно соглашаетесь с тем, что у вас будет работать облако. Т.е. ситуация как с телевизорами LG, когда их поймали на сливе инфы, типо вы же сами ставили галочку - вот мы и сливали. Правда словили на том, что на галочку они не реагировали. Короче суть вопроса в галочке!

Цитата: zmej74
2. в самой прошивке роутера не встроено шпионское ПО, которое потихоньку стучит и принимает команды из вне.


Есть такие порты и протоколы 100%, как на Mikrotik, так и на большинстве ip камер. Есть достаточно много статей об этом. Но рано или поздно такие данные обнародуют и заставляют закрыть.

PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.

Мой телевизор: LG 42

Мой ресивер: Sat-Integral S-1210 HD Aron

Мои спутники:

Cказали Спасибо: 3 : zmej74, Mig777, dimanzik05
Ссылка на пост #6 Добавлено: 2 декабря 2014 23:40
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 34 Водолей
Пол:
С нами: 9 лет 10 месяцев
Сообщений: 6695
Поблагодарил: 5722
Благодарностей: 21763
Предупреждений: 0

Награды:

      

Цитата: sealv
Есть такие порты и протоколы 100%, как на Mikrotik, так и на большинстве ip камер. Есть достаточно много статей об этом. Но рано или поздно такие данные обнародуют и заставляют закрыть.


Да, тоже читал про это. Как раз на микротике, если в локале есть камера, есть коннект с двумя ip сервисов которые работают с потоками камер.

Цитата: sealv
PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.


Одно время сам использовал этот сервис и перестал. Замучили своими письмами. 19
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 2 : zmej74, Mig777
Ссылка на пост #7 Добавлено: 3 декабря 2014 08:45
 
Полное имя: Андрей
Группа: Посетители
Азъ: помогу любому
Возраст: 43 Рыбы
Пол:
С нами: 8 лет 3 месяцa
Сообщений: 883
Поблагодарил: 193
Благодарностей: 1314
Предупреждений: 0

Награды:

   

Короче суть вопроса в галочке!

По-моему, как раз не в галочке, а в чистоплотности некоторых людей.
З.Ы.
УРА! Победил USB-накопитель (флешку или HDD) - работает 68

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: Vu+ Zero, GoldenMedia 990 SR

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 1 : Mig777
Ссылка на пост #8 Добавлено: 3 декабря 2014 09:02
 
Полное имя: Сергей
Группа: Друзья satsis.info
Азъ: почти гуру
Возраст: 38 Стрелец
Пол:
С нами: 7 лет 2 месяцa
Сообщений: 273
Поблагодарил: 7762
Благодарностей: 3318
Предупреждений: 0

Награды:

       

Цитата: maxya
PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.

Одно время сам использовал этот сервис и перестал. Замучили своими письмами.


Для таких регистраций держу отдельный почтовый ящик)) и пускай шлют на здоровье...
Времена не выбирают, в них живут и умирают.
После просмотра канала "Рада" в цирке уже не смеюсь.....

Мой телевизор: LG 42LB650V

Мой ресивер: World Vision ET9200 ET7000mini GI Xfinder

Мои спутники: 4-4.8-9-13-36:-)

Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.
Наш паблик Telegram Наш паблик Viber

    Телесериалы ведущих мировых каналов — теперь в базовом пакете НТВ?ПЛЮС

    Бесплатный доступ к каналу Amedia HIT весь сентябрь!

    «Мультимания» и «Первый Вегетарианский» — новые каналы на платформе НТВ?ПЛЮС

    Канал «Мультимания» вошел в пакет «Детский Запад», «Первый Вегетарианский» – в пакет «Развлекательный Запад».

    Подключите цифровое телевидение и получите 5000 рублей на счет!

    Отличная новость для новых абонентов НТВ?ПЛЮС: подключайтесь до 30 ноября и получите 5000 бонусных рублей на счёт!

    Изменение в вещании НТВ?ПЛЮС

    20 сентября 2017 года на платформе НТВ?ПЛЮС прекращается вещание телеканала CBS Drama.

    Обновляется программное обеспечение для ТВ приставок NTV?PLUS 1 HD VA и NTV?PLUS 1 HD VA PVR

    Доступна новая версия программного обеспечения – 4.3.

    10000 на счёт – «Телекарта» продлевает акцию для новых абонентов!

    Стартует сентябрьский розыгрыш для абонентов с услугой «Приоритет»

    «Приоритет» – это комплексная услуга для абонентов «Телекарты», предоставляющая своим пользователям право на эксклюзивное обслуживания, уникальные услуги и предложения.

    Подарок от «Телекарты» для абонентов: бесплатный доступ к телеканалу «AMEDIA Hit» в течение месяца!

    Начиная с 1 сентября абоненты «Телекарты» получают прекрасную возможность смотреть лучшие сериалы и фильмы на телеканале «AMEDIA Hit».

    Все каналы SPI – теперь в «Телекарте Онлайн»!

    Изменения в программе лояльности «Телекарта Бонус»

    Информируем вас, что C 21 августа вносятся изменения в программу лояльности «Телекарта Бонус»

Телепрограмма

СТБ
01:15 - "Следствие ведут экстрасенсы".
03:05 - Ночной эфир.
-
-
Футбол 1
01:10 - Борнмут - Брайтон энд Хоув Альбион. Чемпионат Англии.
03:05 - Чемпионат Испании. Обзор тура.
04:00 - Валенсия - Малага. Чемпионат Испании.
-
ICTV
01:20 - Т/с "Молодой Волкодав", 1-3 с.
03:35 - Анекдоты по-украински.
04:15 - Служба розыска детей.
04:20 - Студия Вашингтон.
Кинопремьера HD
02:00 - Х/ф "Дед Мороз. Битва магов".
04:15 - Х/ф "Танцы насмерть".
-
-
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Какая скорость вашего интернет соединения

36 кб/сек - телефонная линия
128 кб/сек
256 кб/сек
512 кб/сек
1 мегабит
2 мегабита
5 мегабит
10 мегабит
30 мегабит
50 мегабит
100 мегабит
1 гигабит
GPRS соединение (плавающая скорость)
я в этом ничего не понимаю

Случайное фото

Sat-integral club

Редактор каналов Sat-Integral S-1227, 1247, 1237, 1218, 1225

Господа. Есть новости по редактору каналов? Сейчас открыл список слитый с 1228 с последней прошивки ...

ПО Sat-Integral S-1218HD / S-1228HD версии 2.30

Цитата: afalin от 05 Сентябрь 2017, 22:03:16перегрузили процессор длительной сортировкой Почему ...

ПО Sat-Integral S-1227HD / S-1237HD / S-1247HD версии 2.30

Всім привіт!!! Підскажіть яку прошивку можна використати для Sat-Integral S-1258 HD RACING, список ...

Sat-Integral S-1258 HD RACING

Всім привіт!!! Підскажіть яку прошивку можна використати для Sat-Integral S-1258 HD RACING, список ...

ПО Sat-Integral S-1225 HD Able версии 2.20

На прошивці 2.20 не працює платна шара, на Mgcam .Вернувся на 2.16 все ок.

mysqltuner и mytop на Centos 6.8

Оптимизация ...