Сейчас просматривают тему: 0 -> --, и гостей: 1

Сливаем бекап настроек Mikrotik к себе на email

Ссылка на пост #1 Добавлено: 28 ноября 2014 11:06
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 34 Водолей
Пол:
С нами: 9 лет 10 месяцев
Сообщений: 6695
Поблагодарил: 5722
Благодарностей: 21763
Предупреждений: 0

Награды:

      

Добавляем скрипт в System – Scripts , например с именем backup
После чего добавляем в System – Scheduler задание с именем backup и выбираем желаемый интервал выполнения.
Для проверки скрипта, можно его запустить и получить на почту текущие настройки. Очень полезно когда Вы экспериментируете со своим оборудованием.

Код:[Выделить]
{ :log info "Starting Backup Script..."; :local sysname [/system identity get name]; :local sysver [/system package get system version]; :log info "Flushing DNS cache..."; /ip DNS cache flush; :delay 2; :log info "Deleting last Backups..."; :foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \ "$sysname-backup-"]]!="nil") do={/file remove $i}}; :delay 2; :local smtpserv [:resolve "smtp.hd.zp.ua"]; :local Eaccount "mail@hd.zp.ua"; :local pass "pass00111"; :local backupfile ("$sysname-backup-" . \ [:pick [/system clock get date] 7 11] . [:pick [/system \ clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :log info "Creating new Full Backup file..."; /system backup save name=$backupfile; :delay 2; :log info "Sending Full Backup file via E-mail..."; /tool e-mail send from="< $Eaccount>" to=$Eaccount server=$smtpserv \ port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile \ subject=("$sysname Full Backup (" . [/system clock get date] . ")") \ body=("$sysname full Backup file see in attachment.\nRouterOS version: \ $sysver\nTime and Date stamp: " . [/system clock get time] . " " . \ [/system clock get date]); :delay 5; :local exportfile ("$sysname-backup-" . \ [:pick [/system clock get date] 7 11] . [:pick [/system \ clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc"); :log info "Creating new Setup Script file..."; /export verbose file=$exportfile; :delay 2; :log info "Sending Setup Script file via E-mail..."; /tool e-mail send from="< $Eaccount>" to=$Eaccount server=$smtpserv \ port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile \ subject=("$sysname Setup Script Backup (" . [/system clock get date] . \ ")") body=("$sysname Setup Script file see in attachment.\nRouterOS \ version: $sysver\nTime and Date stamp: " . [/system clock get time] . " \ " . [/system clock get date]); :delay 5; :log info "All System Backups emailed successfully.\nBackuping completed."; }


Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 1 : valdis123
Реклама
Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.
Наш паблик Telegram Наш паблик Viber

    Телесериалы ведущих мировых каналов — теперь в базовом пакете НТВ?ПЛЮС

    Бесплатный доступ к каналу Amedia HIT весь сентябрь!

    «Мультимания» и «Первый Вегетарианский» — новые каналы на платформе НТВ?ПЛЮС

    Канал «Мультимания» вошел в пакет «Детский Запад», «Первый Вегетарианский» – в пакет «Развлекательный Запад».

    Подключите цифровое телевидение и получите 5000 рублей на счет!

    Отличная новость для новых абонентов НТВ?ПЛЮС: подключайтесь до 30 ноября и получите 5000 бонусных рублей на счёт!

    Изменение в вещании НТВ?ПЛЮС

    20 сентября 2017 года на платформе НТВ?ПЛЮС прекращается вещание телеканала CBS Drama.

    Обновляется программное обеспечение для ТВ приставок NTV?PLUS 1 HD VA и NTV?PLUS 1 HD VA PVR

    Доступна новая версия программного обеспечения – 4.3.

    10000 на счёт – «Телекарта» продлевает акцию для новых абонентов!

    Стартует сентябрьский розыгрыш для абонентов с услугой «Приоритет»

    «Приоритет» – это комплексная услуга для абонентов «Телекарты», предоставляющая своим пользователям право на эксклюзивное обслуживания, уникальные услуги и предложения.

    Подарок от «Телекарты» для абонентов: бесплатный доступ к телеканалу «AMEDIA Hit» в течение месяца!

    Начиная с 1 сентября абоненты «Телекарты» получают прекрасную возможность смотреть лучшие сериалы и фильмы на телеканале «AMEDIA Hit».

    Все каналы SPI – теперь в «Телекарте Онлайн»!

    Изменения в программе лояльности «Телекарта Бонус»

    Информируем вас, что C 21 августа вносятся изменения в программу лояльности «Телекарта Бонус»

Телепрограмма

СТБ
01:15 - "Следствие ведут экстрасенсы".
03:05 - Ночной эфир.
-
-
Футбол 1
01:10 - Борнмут - Брайтон энд Хоув Альбион. Чемпионат Англии.
03:05 - Чемпионат Испании. Обзор тура.
04:00 - Валенсия - Малага. Чемпионат Испании.
-
ICTV
01:20 - Т/с "Молодой Волкодав", 1-3 с.
03:35 - Анекдоты по-украински.
04:15 - Служба розыска детей.
04:20 - Студия Вашингтон.
Кинопремьера HD
00:25 - Х/ф "Сделано во Франции".
02:00 - Х/ф "Дед Мороз. Битва магов".
04:15 - Х/ф "Танцы насмерть".
-
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Какая скорость вашего интернет соединения

36 кб/сек - телефонная линия
128 кб/сек
256 кб/сек
512 кб/сек
1 мегабит
2 мегабита
5 мегабит
10 мегабит
30 мегабит
50 мегабит
100 мегабит
1 гигабит
GPRS соединение (плавающая скорость)
я в этом ничего не понимаю

Случайное фото

Sat-integral club

Редактор каналов Sat-Integral S-1227, 1247, 1237, 1218, 1225

Господа. Есть новости по редактору каналов? Сейчас открыл список слитый с 1228 с последней прошивки ...

ПО Sat-Integral S-1218HD / S-1228HD версии 2.30

Цитата: afalin от 05 Сентябрь 2017, 22:03:16перегрузили процессор длительной сортировкой Почему ...

ПО Sat-Integral S-1227HD / S-1237HD / S-1247HD версии 2.30

Всім привіт!!! Підскажіть яку прошивку можна використати для Sat-Integral S-1258 HD RACING, список ...

Sat-Integral S-1258 HD RACING

Всім привіт!!! Підскажіть яку прошивку можна використати для Sat-Integral S-1258 HD RACING, список ...

ПО Sat-Integral S-1225 HD Able версии 2.20

На прошивці 2.20 не працює платна шара, на Mgcam .Вернувся на 2.16 все ок.

mysqltuner и mytop на Centos 6.8

Оптимизация ...