Сейчас просматривают тему: 0 -> --, и гостей: 1

no-ip.org как динамический DNS на Mikrotik

Ссылка на пост #1 Добавлено: 28 ноября 2014 11:16
Автор темы
Макс
Администраторы
Азъ: библиАтекарь
Возраст: 38 Водолей
Пол:
С нами: 13 лет 7 месяцев
Сообщений: 7633
Поблагодарил: 6607
Благодарностей: 24902
Предупреждений: 0

Награды:

       

Сервис динамического обновления ip адреса для Ваших доменов от no-ip.org
Сразу предупреждаю что этот сервис для бесплатной работы, будет засыпать Вас письмами для продления. Не нажали на ссылку, перестанет работать.

И так сам скрипт:

Код:[Выделить]
:local ddnsuser "mail@hd.zp.ua" :local ddnspass "PASS" :local ddnshostname "satsis.no-ip.org" :local ddnsinterface "ISP2" :global ddnslastip [:resolve $ddnshostname]; :global ddnsip [ /ip address get [find interface="ISP2"] address ] :if ([ :typeof $ddnsip ] = "nil" ) do={ :log info ("ServiceDNS: No ip address on $ddnsinterface .") } else={ :for i from=( [:len $ddnsip] - 1) to=0 do={ :if ( [:pick $ddnsip $i] = "/") do={ :set ddnsip [:pick $ddnsip 0 $i]; } } :if ($ddnsip!=$ddnslastip) do={ :log info ("ServiceDNS: $ddnshostname -> $ddnsip") :global str "/nic/update?hostname=$ddnshostname&myip=$ddnsip" /tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname) :global ddnslastip $ddnsip } }


:local ddnsuser “mail@hd.zp.ua” - почта учётной записи
:local ddnspass “pass” - пароль учётной записи
:local ddnshostname “satsis.no-ip.org” – Ваш домен
:local ddnsinterface “ISP2″ – интерфейс с динамическим ip
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube, maxya Тётя шура тут
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1248 HD Heavy Metal, VU+ Ultimo 4K

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 3 : kolobokru, valdis123, Mig777
Ссылка на пост #2 Добавлено: 1 декабря 2014 14:30
Андрей
Посетители
Азъ: помогу любому
Возраст: 47 Рыбы
Пол:
С нами: 12 лет
Сообщений: 944
Поблагодарил: 225
Благодарностей: 1435
Предупреждений: 0

Награды:

   

А не проще ли использовать встроенный в RouterOS сервис Cloud, который сам назначит роутеру имя на DDNS сервере и будет сам следить за изменением IP?

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: ZGemma H7S, Openbox Prismcube Ruby

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 1 : Mig777
Ссылка на пост #3 Добавлено: 1 декабря 2014 15:43
Автор темы
Макс
Администраторы
Азъ: библиАтекарь
Возраст: 38 Водолей
Пол:
С нами: 13 лет 7 месяцев
Сообщений: 7633
Поблагодарил: 6607
Благодарностей: 24902
Предупреждений: 0

Награды:

       

Цитата: zmej74
А не проще ли использовать встроенный в RouterOS сервис Cloud, который сам назначит роутеру имя на DDNS сервере и будет сам следить за изменением IP?


А сами пробовали?
Я вообще стараюсь такие сервисы обходить стороной по 2м причинам:
1. Активируя его, Вы сами соглашаетесь дать доступ облаку к вашему тику. Порт никак не контролируется и может использоваться как угодно, хоть для активации DDOS атак с вашего оборудования.
2. Скорее всего есть какой-то публичный сервис где Ваш тик будет светить синим светом, маня всевозможных кулхацкеров в гости.

+ ко всему скриптом выше можно самостоятельно назначать домен который хотите, можно делать интервал времени проверки.
Да и никто не заставляет что-то самому писать
вставил скрипт, поменял значения на свои и используй.
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube, maxya Тётя шура тут
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1248 HD Heavy Metal, VU+ Ultimo 4K

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 1 : Mig777
Ссылка на пост #4 Добавлено: 2 декабря 2014 08:57
Андрей
Посетители
Азъ: помогу любому
Возраст: 47 Рыбы
Пол:
С нами: 12 лет
Сообщений: 944
Поблагодарил: 225
Благодарностей: 1435
Предупреждений: 0

Награды:

   

А сами пробовали?

конечно пробовал! Этот сервис создает на Микротиковском сервере учетку так же как и на no-ip. Только учетка не очень удобочитаемая.
Ну и не нужно выполнять операции по регистрации имени - все сделает роутер. И дальше будет синхронизировать адрес IP. В принципе, будет делать то же что и твой скрипт - только автоматом.
А на работе я использую белый статический IP. Ибо, по-моему, брать такой аппарат и сэкономить на IP...
Активируя его, Вы сами соглашаетесь дать доступ облаку к вашему тику. Порт никак не контролируется и может использоваться как угодно, хоть для активации DDOS атак с вашего оборудования

Совсем наоборот - тик получает доступ к DDNS серверу. Если уж так заботиться о безопасности - где гарантия что:
1. бесплатные DDNS сервера (no-ip) не сливают свои базы и не организовывают DDOS атаки?
2. в самой прошивке роутера не встроено шпионское ПО, которое потихоньку стучит и принимает команды из вне.

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: ZGemma H7S, Openbox Prismcube Ruby

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 3 : sealv, maxya, Mig777
Ссылка на пост #5 Добавлено: 2 декабря 2014 22:14
Владимир
Друзья satsis.info
Азъ: интересующийся
Возраст: 34 Дева
Пол:
С нами: 8 лет 8 месяцев
Сообщений: 28
Поблагодарил: 20
Благодарностей: 52
Предупреждений: 0

Репутация:

Награды:

 

Цитата: zmej74
Ну и не нужно выполнять операции по регистрации имени


В этой ветке есть скрипт для Cloudflare, там не нужно активировать домен как no-ip каждый месяц. Там один раз и на долго. Количество доменов не ограничено!

Цитата: zmej74
В принципе, будет делать то же что и твой скрипт - только автоматом.


Ну суть вопроса наверное еще во времени выполнения смены ip, скриптом вы сами определяете интервал. Ну + ко всему, как я понял. Динамически еще обновляется проброс портов и маршруты.

Цитата: zmej74
А на работе я использую белый статический IP. Ибо, по-моему, брать такой аппарат и сэкономить на IP...

Ну на работе то понятно, а платить например киевстару 35 грн за белый ip как по мне не резонно. Особенно если тариф на интернет 70-80 грн. Закинул скрипт и живи спокойно.

Цитата: zmej74
1. бесплатные DDNS сервера (no-ip) не сливают свои базы и не организовывают DDOS атаки?

Суть вопроса не в том даже что сливают, а в том что вы по сути ставя галочку в этом пункте роутера, добровольно соглашаетесь с тем, что у вас будет работать облако. Т.е. ситуация как с телевизорами LG, когда их поймали на сливе инфы, типо вы же сами ставили галочку - вот мы и сливали. Правда словили на том, что на галочку они не реагировали. Короче суть вопроса в галочке!

Цитата: zmej74
2. в самой прошивке роутера не встроено шпионское ПО, которое потихоньку стучит и принимает команды из вне.


Есть такие порты и протоколы 100%, как на Mikrotik, так и на большинстве ip камер. Есть достаточно много статей об этом. Но рано или поздно такие данные обнародуют и заставляют закрыть.

PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.

Мой телевизор: LG 42

Мой ресивер: Sat-Integral S-1210 HD Aron

Мои спутники:

Cказали Спасибо: 3 : zmej74, Mig777, dimanzik05
Ссылка на пост #6 Добавлено: 2 декабря 2014 23:40
Автор темы
Макс
Администраторы
Азъ: библиАтекарь
Возраст: 38 Водолей
Пол:
С нами: 13 лет 7 месяцев
Сообщений: 7633
Поблагодарил: 6607
Благодарностей: 24902
Предупреждений: 0

Награды:

       

Цитата: sealv
Есть такие порты и протоколы 100%, как на Mikrotik, так и на большинстве ip камер. Есть достаточно много статей об этом. Но рано или поздно такие данные обнародуют и заставляют закрыть.


Да, тоже читал про это. Как раз на микротике, если в локале есть камера, есть коннект с двумя ip сервисов которые работают с потоками камер.

Цитата: sealv
PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.


Одно время сам использовал этот сервис и перестал. Замучили своими письмами. 19
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube, maxya Тётя шура тут
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1248 HD Heavy Metal, VU+ Ultimo 4K

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 2 : zmej74, Mig777
Ссылка на пост #7 Добавлено: 3 декабря 2014 08:45
Андрей
Посетители
Азъ: помогу любому
Возраст: 47 Рыбы
Пол:
С нами: 12 лет
Сообщений: 944
Поблагодарил: 225
Благодарностей: 1435
Предупреждений: 0

Награды:

   

Короче суть вопроса в галочке!

По-моему, как раз не в галочке, а в чистоплотности некоторых людей.
З.Ы.
УРА! Победил USB-накопитель (флешку или HDD) - работает 68

Мой телевизор: Toshiba 32HV10V1

Мой ресивер: ZGemma H7S, Openbox Prismcube Ruby

Мои спутники: Amos+Sirius+Hotbird+Eutelsat

Cказали Спасибо: 1 : Mig777
Ссылка на пост #8 Добавлено: 3 декабря 2014 09:02
Сергей
Друзья satsis.info
Азъ: почти гуру
Возраст: 42 Стрелец
Пол:
С нами: 11 лет
Сообщений: 277
Поблагодарил: 8070
Благодарностей: 3399
Предупреждений: 0

Награды:

       

Цитата: maxya
PS я бы не использовал сервис no-ip из-за постоянной нужды активации и горы спама который они шлют на почту.

Одно время сам использовал этот сервис и перестал. Замучили своими письмами.


Для таких регистраций держу отдельный почтовый ящик)) и пускай шлют на здоровье...
Времена не выбирают, в них живут и умирают.
После просмотра канала "Рада" в цирке уже не смеюсь.....

Мой телевизор: LG 42LB650V

Мой ресивер: World Vision ET9200 ET7000mini GI Xfinder

Мои спутники: 4-4.8-9-13-36:-)

Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    XML error in File: https://ntvplus.ru/rss/company

    XML error: at line 0
    {inform_telekarta}

Футбол

Чемпионат Европы, Групповой этап. 3-й тур
23 июня 2021
19:00 Словакия Словакия 0:5 ИспанияИспания
19:00 Швеция Швеция 3:2 ПольшаПольша
22:00 Германия Германия 2:2 ВенгрияВенгрия
22:00 Португалия Португалия 2:2 ФранцияФранция

Обновлено: 15:21 25.06.2021

Телепрограмма

СТБ
14:50 - "Слепая".
17:35 - "Вікна-Новини".
18:55 - "Слепая".
25:15 - Х/ф "Любовница в наследство", 1 и 2 с.
Футбол 1
15:15 - Д/с "Классика Евро". Англия - Румыния (2000).
15:45 - Швейцария - Турция. Чемпионат Европы 2020.
17:45 - Д/с "Официальная история UEFA Евро", 7 с.
18:35 - Словакия - Испания. Чемпионат Европы 2020.
ICTV
14:40 - Т/с "Тайные двери".
15:45 - Факты. День.
16:15 - Х/ф "Инферно".
18:45 - Факты. Вечер.
Кинопремьера HD
15:15 - Х/ф "Стрельцов".
16:55 - Х/ф "Избави нас от лукавого".
18:45 - Х/ф "Капоне. Лицо со шрамом".
25:35 - Х/ф "Заклятье. Другая сторона".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Какая стоимость вашего ресивера?

до 50$
50-100$
100-150$
150-200$
200-250$
250-300$
300-350$
350-400$
400-450$
450-500$
500$ и выше...

Случайное фото

Sat-integral club

IPTV на S-1218HD Able

Плейлист.

Ключи Sat-Integral S-1210 HD Aron

обновились ключи PowerVu Код: [Выделить]DISCOVERY EUROPE 4.8°E 12322 V 27500 Key0-7ECD9C0F627ED5↔ ...

Sat-Integral SP-1329 HD Combo

Цитата: danver от 23 Июнь 2021, 11:37:46но EAC3 работать уже не будет. А доработать поддержку EAC3 ...

Sat-Integral SP-1329 HD Combo

Ресивер поддерживает программное декодирование звука AC3 (в т.ч. медиаплеером), но EAC3 работать ...

ПО Sat-Integral S-1218-28HD / S-1248-58-68HD / S-1311 HD COMBO v3.12

Цитата: sergijuk от 22 Июнь 2021, 19:00:24Есть четыре способа как пользоваться IPTV: 1. Прописать ...

Киевстар списал всё

Не успели ...

Mixed Content при обращении к WebSocket

Ситуация, когда у ...