Сейчас просматривают тему: 0 -> --, и гостей: 1

Сливаем бекап настроек Mikrotik к себе на email

Ссылка на пост #1 Добавлено: 28 ноября 2014 11:06
Автор темы
Макс
Администраторы
Азъ: библиАтекарь
Возраст: 37 Водолей
Пол:
С нами: 13 лет 1 месяц
Сообщений: 7442
Поблагодарил: 6450
Благодарностей: 24530
Предупреждений: 0

Награды:

       

Добавляем скрипт в System – Scripts , например с именем backup
После чего добавляем в System – Scheduler задание с именем backup и выбираем желаемый интервал выполнения.
Для проверки скрипта, можно его запустить и получить на почту текущие настройки. Очень полезно когда Вы экспериментируете со своим оборудованием.

Код:[Выделить]
{ :log info "Starting Backup Script..."; :local sysname [/system identity get name]; :local sysver [/system package get system version]; :log info "Flushing DNS cache..."; /ip dns cache flush; :delay 2; :log info "Deleting last Backups..."; :foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \ "$sysname-backup-"]]!="nil") do={/file remove $i}}; :delay 2; :local smtpserv [:resolve "smtp.hd.zp.ua"]; :local Eaccount "mail@hd.zp.ua"; :local pass "pass00111"; :local backupfile ("$sysname-backup-" . \ [:pick [/system clock get date] 7 11] . [:pick [/system \ clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :log info "Creating new Full Backup file..."; /system backup save name=$backupfile; :delay 2; :log info "Sending Full Backup file via E-mail..."; /tool e-mail send from="< $Eaccount>" to=$Eaccount server=$smtpserv \ port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile \ subject=("$sysname Full Backup (" . [/system clock get date] . ")") \ body=("$sysname full Backup file see in attachment.\nRouterOS version: \ $sysver\nTime and Date stamp: " . [/system clock get time] . " " . \ [/system clock get date]); :delay 5; :local exportfile ("$sysname-backup-" . \ [:pick [/system clock get date] 7 11] . [:pick [/system \ clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc"); :log info "Creating new Setup Script file..."; /export verbose file=$exportfile; :delay 2; :log info "Sending Setup Script file via E-mail..."; /tool e-mail send from="< $Eaccount>" to=$Eaccount server=$smtpserv \ port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile \ subject=("$sysname Setup Script Backup (" . [/system clock get date] . \ ")") body=("$sysname Setup Script file see in attachment.\nRouterOS \ version: $sysver\nTime and Date stamp: " . [/system clock get time] . " \ " . [/system clock get date]); :delay 5; :log info "All System Backups emailed successfully.\nBackuping completed."; }


Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube, maxya Тётя шура тут
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1248 HD Heavy Metal, VU+ Ultimo 4K

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Cказали Спасибо: 1 : valdis123
Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    XML error in File: https://ntvplus.ru/rss/company

    XML error: at line 0
    {inform_telekarta}

Футбол

Лига Европы, Групповой этап. 5 тур
03 декабря 2020
19:55 Гент 1:2 Слован Либерец
19:55 Црвена Звезда 0:0 Хоффенхайм
19:55 Фейеноорд 0:2 Динамо Загреб
19:55 ЦСКА М 0:1 Вольфсберг
19:55 Антверпен 3:1 Лудогорец
19:55 АЕК Афины 2:4 Брага
19:55 Милан 4:2 Селтик
19:55 Лилль 2:1 Спарта П
19:55 Карабах 1:1 Маккаби Тель-Авив
19:55 Сивасспор 0:1 Вильярреал
19:55 ЛАСК 3:3 Тоттенхэм
19:55 Заря 1:0 Лестер Сити
22:00 Реал Сосьедад  0:0  Риека
22:00 АЗ Алкмаар  0:1  Наполи
22:00 Омония  1:0  ПАОК
22:00 Гранада  0:0  ПСВ
22:00 Бенфика  0:0  Лех
22:00 Ницца  0:0  Байер
22:00 Мольде  0:0  Дандолк
22:00 Славия Прага  0:0  Хапоэль Беер-Шева
22:00 Рома  0:0  Янг Бойз
22:00 ЧФР Клуж  0:0  ЦСКА София
22:00 Арсенал  2:0  Рапид Вн
22:00 Рейнджерс  0:1  Стандард

Обновлено: 22:19 03.12.2020

Телепрограмма

СТБ
22:00 - "Вікна-Новини".
22:50 - Т/с "Цвет страсти", 16 с.
23:05 - Т/с "Никонов и Ко", 7 и 8 с.
01:05 - "Следствие ведут экстрасенсы".
Футбол 1
21:50 - "Шлях до Гданська". Прямой эфир.
22:30 -  "Лига Европы. Online". 1-й тайм. Прямая трансляция.
22:45 - Футбол News.
23:00 -  "Лига Европы. Online". 2-й тайм. Прямая трансляция.
ICTV
21:30 - Т/с "Пес 3", 8 с.
22:45 - Т/с "Фантом", 5 и 6 с.
00:50 - Х/ф "Дрожь земли 4: Легенда начинается".
02:35 - Антизомби. Дайджест.
Кинопремьера HD
21:05 - Х/ф "Прекрасная эпоха".
23:00 - Х/ф "Пока свадьба не разлучит нас".
00:45 - Х/ф "Черное и синее".
02:30 - Х/ф "Хороший доктор".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Какой у вас спутниковый ресивер?

VU+
Sat-Integral
SkyWay
Golden Media
Galaxy Innovations
Amiko
Tiger
Openbox
SkyGate
Dreambox
AZbox
Octagon
Opticum
Eurosat
Eurosky
Globo
Humax
General Satellite
Golden Interstar
Topfield
IPBox
Evolution
Kathrein
Technosat
Samsung
XCRUISER
DVB карта
другой ресивер

Случайное фото

Sat-integral club

ПО Sat-Integral S-1223 HD Rocket / S-1224 HD STEALTH MODERN версии 3.80 (fix)

А может всё таки "допилять" прошивку, так, что бы можно было пользоваться рейсом по ...

IPTV на S-1218HD Able

Цитата: vviktorgygo от Сегодня в 09:26:51Ну тогда вся надежда только на Функам. Нормального  ...

Вопросы новичков

Цитата: Андрей777 от Сегодня в 08:53:58Я поставил на ноут спец. программу для iptv листов которая ...

Пожелания разработчикам ПО Sat-Integral SP-1219 / SP-1229 / SP-12x9

Цитата: Ricky_Gerad от 01 Декабрь 2020, 20:30:17Це реалізовано в опенфокс.Не думаю що це так ...

ПО Sat-Integral S-1223 HD Rocket / S-1224 HD STEALTH MODERN версии 3.80 (fix)

Цитата: Yuriiy от 01 Декабрь 2020, 16:50:33Youtube работает, но для меня он совершенно не ...

Covid-19 Телеграм бот @uacovid_bot

Небольшой телеграм ...
{**}