Сейчас просматривают тему: 0 -> --, и гостей: 1

Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2

Ссылка на пост #1 Добавлено: 5 октября 2015 12:22
Автор темы  
Полное имя: Макс
Группа: Администраторы
Азъ: библиАтекарь
Возраст: 33 Водолей
Пол:
С нами: 9 лет 1 месяц
Сообщений: 6375
Поблагодарил: 5498
Благодарностей: 20248
Предупреждений: 0

Награды:

     

Базовая настройка двух провайдеров на Mikrotik.

Т.к. Mirkotik способен работать одновременно с несколькими провайдерами, возникает необходимость получать доступ к самому Mikrotikу или внутренним ресурсам локальной сети также и с других провайдеров. По умолчанию Mikrotik доступен только с провайдера, шлюз которого используется по умолчанию. Поэтому ув. erazel попытается “на яблоках” объяснить что нужно сделать для полноценного использования второго или другого провайдера, подключенного к роутеру.

Пример будет для второго провайдера Укртелеком.
Будем считать что у вас два аплинка со статическими ip адресами, в случае с динамическими ip, необходимо будет порвань несколько бубнов и использовать скрипты для изменения gateway провайдера.

1. Даем метку для дефолтного маршрута через ISP2 и маршрута к шлюзу(что бы роутер знал через какой интерфейс обращаться к шлюзу)

Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


Код:[Выделить]
/ip route add distance=1 dst-address=0.0.0.0/0 gateway=195.5.147.1 routing-mark=oo scope=10


195.5.147.1 – gateway Укртелекома, у вас будет другой ip

Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


2. Весь входящий трафик через интерфейс ISP2 и не имеющий еще маркировки, мы маркируем соответствующим конекшн-марком

Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


Код:[Выделить]
/ip firewall mangle add action=mark-connection chain=prerouting comment=oo connection-mark=no-mark in-interface=ISP2 new-connection-mark=ISP2


Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


3. Трафик вошедший в роутер через второй аплинк ISP2 и выходящий не в интерфейс локалки (тоесть трафик самого роутера идущий как ответный на запросы из интернета) мы отправляем по маркированому маршруту

Код:[Выделить]
/ip firewall mangle add action=mark-routing chain=output connection-mark=ISP2 new-routing-mark=oo out-interface=!bridge-local

Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


Для чего это? Иначе пакет будет смотреть основную таблицу маршрутизации, а там указан основным шлюзом ISP1

4. Трафик идущий от клиентов локалки (подсеть 192.168.0.0/16) и имеющий нужный конекшнмарк мы тоже отправляем через маркированый маршрут. Мы могли или сами до этого промаркировать трафик по нужному критерию или же это ответный трафик на запросы из интернета(если у нас есть проброс портов)

Код:[Выделить]
/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=ISP2 new-routing-mark=oo src-address=192.168.0.0/16


или

Код:[Выделить]
/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=ISP2 in-interface=bridge-local new-routing-mark=oo


Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2Доступ к локальным ресурсам Mikrotik через 2го провайдера ISP2


так же вместо src-address= можно указать интерфейс локалки in-interface= . В чем кардинальная разница? Ну во втором случае у нас могут быть за одним портом/бриджом несколько разных подсетей, с данным параметром не придется для каждой делать отдельное правило.

Этих правил хватит что бы сам роутер жил с двумя аплинками и успешно пробрасывал порты с двух внешних интерфейсов.
Если же вы хотите еще и разделять клиентов локалки по разным аплинкам динамически то надо читать статью из заголовка.
если же нам надо сугубо конкретные адреса/порты то достаточно простого правила типа такого:

Код:[Выделить]
/ip firewall mangle add action=mark-routing chain=prerouting dst-port=22 new-routing-mark=ukrtelecom protocol=tcp src-address=192.168.0.62


Не обязательно использовать все поля. Можно обойтись только src.адресом если нам надо весь трафик конкретной машины отправить через второй шлюз. Если же мы укажем еще и порт то весь трафик кроме этого порта пойдет через дефолтный маршрут, а трафик к этому порту пойдет через маркрированый маршрут. Полезно если мы не хотим забивать торентами основной канал. Достаточно указать срц.порт=порту_торент_клиента.

Англоязычную полную информацию можно найти по адресу Manual:PCC

Материал подготовил erazel

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1210 HD Aron, Sat-Integral TH-7200 PVR I, iNeXT HD1, GI Vu+ Duo 2

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Реклама
Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    Новый виток развития телевидения — дроны

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» совместно с НП «ГЛОНАСС» и телеканалом Life запускает федеральный проект «Россия глазами дронов»

    Индустрия дронов — будущее России

    1 декабря 2016 года на пресс-конференции по Кубку чемпионов по дрон-рейсингу в рамках «Транспортной недели-2016» помощник Президента России Игорь Левитин, заместитель министра транспорта Алексей Цыденов, президент НП «ГЛОНАСС» Александр Гурко и генеральный директор «Триколор ТВ» Алексей Холодов обсудят перспективы развития отрасли беспилотных авиационных систем (БАС) в России и их применение в телекоммуникационной отрасли

    «Триколор ТВ» признан самым инновационным оператором Европы

    25 ноября 2016 года российский оператор цифрового телевидения «Триколор ТВ» единственный из европейских операторов стал обладателем премии за внедрение инновационных сервисов и технологий в рамках международной премии Eutelsat TV Awards

    «Триколор ТВ» принял участие на RIW–2016

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» впервые принял участие на Russian Interactive Week

    «Триколор ТВ» увеличил сервисный охват в четыре раза

    В IV квартале 2016 года фирменная розничная сеть крупнейшего российского оператора цифрового телевидения «Триколор ТВ» расширилась до 400 Центров продаж и обслуживания и монобрендовых салонов-магазинов

    Абоненты Телекарты получают «Приоритет»

    «Приоритет» – это комплексная услуга для абонентов «Телекарты», предоставляющая своим пользователям право на эксклюзивное обслуживания, уникальные услуги и предложения.

    «Премия Рунета» досталась «Телекарте Онлайн»

    SMART TV ОТ «ТЕЛЕКАРТЫ» ТЕПЕРЬ В LG!

    Как мы и обещали, линейка «умных» телевизоров, на которых доступна «Телекарта Онлайн» пополнилась модельным рядом телевизоров LG!

    TOPSONG TV и DANGE TV меняют название

    TOPSONG TV и DANGE TV меняют название

    Предпоказ сериала «Юная» в онлайн кинотеатре

    Телеканал Sony Entertainment Television предоставляет возможность посмотреть первые 2 серии комедийного сериала «Юная» еще до премьеры на телеканале.

Телепрограмма

СТБ
07:10 - "Всё будет хорошо!".
09:00 - "Всё будет вкусно!".
10:00 - "Караоке на Майдане".
11:00 - Т/с "Когда мы дома", 87-90 с.
Футбол 1
07:45 - Мир Премьер-лиги.
08:15 - Барселона - Реал Мадрид. Чемпионат Испании.
10:00 - Футбол News. Live.
10:20 - "Моя игра". Якоб Галл.
ICTV
07:05 - Что? Где? Когда? Интеллектуальное шоу.
08:10 - Смотреть всем!
10:10 - Премьера. Лучше не повторяй. Развлекательное шоу.
11:10 - Х/ф "Индиана Джонс. В поисках утраченного ковчега", 1 ч.
Кинопремьера HD
07:25 - Х/ф "Фрэнк".
09:00 - Х/ф "Хозяин джунглей".
10:40 - Х/ф "Чужая страна".
12:30 - Х/ф "Конец прекрасной эпохи".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Какой провайдер спутникового ТВ вы смотрите?

НТВ Плюс
Радуга ТВ
Виасат Украина
Xtra TV
Триколор ТВ
Континент ТВ
Телекарта
Рикор ТВ
Взрослый
Все понемногу

Случайное фото

Sat-integral club

переделка конвектора

Цитата: nikon от Вчера в 18:38:00Щас переделаю  отпишусь что получится Добавлено: Вчера в ...

Разработчикам, добавьте драйвера в прошивку

Цитата: IAndrusjak от 05 Декабрь 2014, 13:22:35Sat Integral S1223 HD Rocket отлично работает и с ...

Продление G-share

Цитата: Павел от Вчера в 20:21:56а зайдя в сервера,стать на 40 сервер-F1-выбрать ДА-Ок. перегруз ...

Неисправности

Всем добрый вечер всё затёрто немогу понять подскажите какая флэш-память стоит в приборе SAT ...

ПО для ресивера Sat-Integral S-1226 HD K3 от 2016.12.02

Цитата: serguly от Вчера в 20:15:46Цитата: sir.floyd от Вчера в 16:18:03а поподробней пожалуйста ...

Установка MySQL 5.6 на Centos 6

Будем использовать ...