Сейчас просматривают тему: 0 -> --, и гостей: 1

Mikrotik: Две сети с одинаковыми адресными пространствами

Ссылка на пост #1 Добавлено: 24 января 2016 19:51
Автор темы  
Полное имя: Сергій
Группа: Друзья satsis.info
Азъ: интересующийся
Возраст: 34 Близнецы
Пол:
С нами: 1 год 11 месяцев
Сообщений: 66
Поблагодарил: 14
Благодарностей: 62
Предупреждений: 0

Репутация:

Награды:

 

Зачастую пользователи оставляют дефолтный настройки на роутерах. И так случается что адресные пространства домашних/рабочих локалок лежат в 192.168.0.0/24, 192.168.1.0/24 и других подобных указанных в заводских настройках оборудования.
Но вот наступает момент, когда необходимо соеденить две сети между собой. И тут наступает неприятное просветление – адреса идентичны. Причем каждый админ не хочет менять адреса своей сети, ведь всюду настроены правила под конкретные адреса. Что делать когда иметь связь с другой сетью хочется, а менять свои адреса нет? Тогда нам на помощь приходит NAT.
Вводная:
172.16.0.1 – адрес на интерфейсе(соеденяющем два роутера между собой) Mikrotik1
172.16.0.2 – адрес на интерфейсе(соеденяющем два роутера между собой) Mikrotik2
192.168.0.0/24 –адресное пространство обеих локальных сетей


Первым делом укажем что за другим роутером находится «виртуальная»(ее там нет на самом деле) подсеть

На Mikrotik1

Код:[Выделить]
/ip route add distance=1 dst-address=192.168.222.0/24 gateway=172.16.0.2

На Mikrotik2

Код:[Выделить]
/ip route add distance=1 dst-address=192.168.111.0/24 gateway=172.16.0.1

Так трафик к этим «подставным» сетям будет уходить к соседнему роутеру.
Потом надо перенаправлять подставные сети на реальные
На Mikrotik1

Код:[Выделить]
/ip firewall nat add action=netmap chain=dstnat dst-address=192.168.111.0/24 to-addresses=192.168.0.0/24

На Mikrotik2

Код:[Выделить]
/ip firewall nat add action=netmap chain=dstnat dst-address=192.168.222.0/24 to-addresses=192.168.0.0/24

Что это делает? Эти правила трафик к 192.168.ххх.0/24 подсети направляют в локалку. action=netmap - предназначен для трансляции сетей «1к1» . Тесть 192.168.111.28 будет странслирован в 192.168.0.28

Вот, теперь из локалки Mikrotik1 можно обращаться к сети 192.168.222.0/24 и трафик уйдет на соответствующие хосты локалки Mikrotik2 (соответственно из локалки Mikrotik2 обращение к 192.168.111.0/24 уйдет к локалке Mikrotik1)

Но это только половина задачи. Ведь адрес источника остался прежним 192.168.0.х , он будет считаться локальным и ответ не пойдет к роутеру, а уйдет в локалку. Для этого надо смаскарадить src-address в пакетах.
на Mikrotik1

Код:[Выделить]
/ip firewall nat add action=netmap chain=srcnat src-address=192.168.0.0/24 out_interface=XXXX to-addresses=192.168.111.0/24

На Mikrotik2

Код:[Выделить]
/ip firewall nat add action=netmap chain=srcnat src-address=192.168.0.0/24 out_interface=XXXX to-addresses=192.168.222.0/24

Где ХХХ это интерфейс роутера который связывает два роутера между собой.
Теперь в пакетах адрес источника будет так же подменяться и ответы будут уходить на шлюз локалки, а он уже перенаправлять на другой роутер

Вот теперь мы получили ситуацию когда локалка Mikrotik1 будет видеть локалку Mikrotik2 как 192.168.222.0/24, а локалка Mikrotik2 будет видеть локалку Mikrotik1 как 192.168.111.0/24 . То есть обращаться нужно будет именно по этим подставным адресам.

Мой телевизор: Sony KDL-32U4000

Мой ресивер: SkyPrime HD

Мои спутники: еще ниодного

Cказали Спасибо: 2 : maxya, zmej74
Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    «Триколор ТВ» и Mezzo: эффективная реализация международных принципов пакетирования

    «Триколор ТВ» и телеканал Mezzo организуют прямую трансляцию исполнения мирового шедевра

    Новый виток развития телевидения — дроны

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» совместно с НП «ГЛОНАСС» и телеканалом Life запускает федеральный проект «Россия глазами дронов»

    Индустрия дронов — будущее России

    1 декабря 2016 года на пресс-конференции по Кубку чемпионов по дрон-рейсингу в рамках «Транспортной недели-2016» помощник Президента России Игорь Левитин, заместитель министра транспорта Алексей Цыденов, президент НП «ГЛОНАСС» Александр Гурко и генеральный директор «Триколор ТВ» Алексей Холодов обсудят перспективы развития отрасли беспилотных авиационных систем (БАС) в России и их применение в телекоммуникационной отрасли

    «Триколор ТВ» признан самым инновационным оператором Европы

    25 ноября 2016 года российский оператор цифрового телевидения «Триколор ТВ» единственный из европейских операторов стал обладателем премии за внедрение инновационных сервисов и технологий в рамках международной премии Eutelsat TV Awards

    «Триколор ТВ» принял участие на RIW–2016

    Крупнейший российский оператор цифрового телевидения «Триколор ТВ» впервые принял участие на Russian Interactive Week

    Конкурс детской новогодней открытки

    В преддверии Нового года Телекарта и Канал Disney представляют конкурс детской новогодней открытки!

    Абоненты Телекарты получают «Приоритет»

    «Приоритет» – это комплексная услуга для абонентов «Телекарты», предоставляющая своим пользователям право на эксклюзивное обслуживания, уникальные услуги и предложения.

    «Премия Рунета» досталась «Телекарте Онлайн»

    SMART TV ОТ «ТЕЛЕКАРТЫ» ТЕПЕРЬ В LG!

    Как мы и обещали, линейка «умных» телевизоров, на которых доступна «Телекарта Онлайн» пополнилась модельным рядом телевизоров LG!

    TOPSONG TV и DANGE TV меняют название

    TOPSONG TV и DANGE TV меняют название

Телепрограмма

СТБ
11:55 - "МастерШеф. Дети".
16:00 - "Всё будет хорошо!".
18:00 - "Викна-Новости".
18:30 - "За живе!".
Футбол 1
12:05 - "Лига чемпионов. Online".
13:55 - Реал Мадрид - Боруссия Дортмунд. Лига чемпионов. Сезон 2012/2013.
15:40 - Футбол News. Live.
16:00 - "Ночь Лиги чемпионов".
ICTV
11:55 - Х/ф "Васаби", 1 ч.
12:45 - Факты. День.
13:20 - Х/ф "Васаби", 2 ч.
14:25 - Премьера. Т/с "Отдел 44", 105 и 106 с.
Кинопремьера HD
12:15 - Х/ф "Китайская головоломка".
14:10 - Х/ф "Вторая жизнь Уве".
16:05 - Х/ф "Родина".
18:00 - Х/ф "Принц".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Откуда вы?

Украина
Россия
Белоруссия
Германия
США
Англия
другая страна...

Случайное фото

Sat-integral club

Продление Funcam

Цитата: serg1557733 от Вчера в 22:22:48фанкам глючит , работает отвратительно, покупал ресивер ...

Загрузчик для восстановления ресивера Sat-Integral S-1226 HD K3 / FreeNet S2X HD

Цитата: Rust6 от Сегодня в 09:14:59тюнер завис - черный экран на телеке и на ресивере горит только ...

Продление Funcam

платный я на любом ресе подключить могу- а здесь смысл этого полуресивера в шаре, иначе грошь ему ...

Загрузчик для восстановления ресивера Sat-Integral S-1226 HD K3 / FreeNet S2X HD

тюнер завис - черный экран на телеке и на ресивере горит только зеленый светодиод. Я так понимаю ...

Продление G-share

Цитата: sergo.lug от Вчера в 19:46:26Добрый вечер, Павел. Сегодня в 16-10 кошелёк z312334001373 от ...

Установка MySQL 5.6 на Centos 6

Будем использовать ...