Сейчас просматривают тему: 0 -> --, и гостей: 1

Проброс локального порта Mikrotik на Centos 6 через l2tp

Ссылка на пост #1 Добавлено: 18 января 2021 11:44
Автор темы
Макс
Администраторы
Азъ: библиАтекарь
Возраст: 38 Водолей
Пол:
С нами: 14 лет 2 месяцa
Сообщений: 7855
Поблагодарил: 6696
Благодарностей: 25158
Предупреждений: 0

Награды:

       

С пробросом локального порта на внешний белый ip адрес роутера Mikrotik, это вполне решаемая задача.

Код:[Выделить]
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.0.31 to-ports=80 protocol=tcp dst-address=124.239.16.214 dst-port=8880 log=no



Но что делатьл если необходимо пробросить локальный порт на сервер Centos через l2tp соединение. Ведь по умолчанию Mikrotik будет отдавать пакеты через дефолтный шлюз.
Зачем пробрасывать порт?
Например, у нас есть подключение к сети интернет с серым ip адресом и нам необходимо предоставить серверу на Centos подключаться к видео регистратору или Ip камере внутренней локальной сети Mikrotik.

Код:[Выделить]
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.150 to-ports=559 protocol=tcp dst-address=10.0.0.10 dst-port=559 log=no log-prefix=""


Где 192.168.0.150 локальный адрес регистратора, внутренней сети Mikrotik
to-ports=559 — rtsp порт регистратора, по умолчанию 554
dst-address=10.0.0.10 — локальный адрес l2tp клиента Mikrotik

Код:[Выделить]
/ip firewall mangle add chain=input action=mark-connection new-connection-mark=reg-conn passthrough=yes in-interface=l2tp-out_cam1 log=no log-prefix="" /ip firewall mangle add chain=output action=mark-routing new-routing-mark=reg-route passthrough=no connection-mark=reg-conn log=no log-prefix="" /ip firewall mangle add chain=forward action=mark-connection new-connection-mark=reg-conn-f passthrough=no in-interface=l2tp-out_cam1 log=no log-prefix="" /ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=reg-route passthrough=yes connection-mark=reg-conn-f in-interface=bridge log=no log-prefix=""


И в конце создаём route
dst-address=0.0.0.0/0
Gateway = 10.0.0.1 — это Remote address нашего l2tp соединения (т.е. адрес l2tp Centos сервера)
Routing Mark = reg-route

В итоге порт прокинут. Пакеты побежали по всем правилам которые мы создали.

На виртуалке (вашем серверве с белым ip): /etc/sysctl.conf

Код:[Выделить]
net.ipv4.ip_forward = 1


Код:[Выделить]
sysctl -p


Код:[Выделить]
iptables -A FORWARD -p udp --sport 1701 -j ACCEPT iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 554 -j ACCEPT iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 8000 -j ACCEPT iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 8291 -j ACCEPT iptables -A INPUT -m state --state NEW -m tcp -p tcp --dport 8888 -j ACCEPT iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 554 -j DNAT --to 10.0.0.10:554 iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 8000 -j DNAT --to 10.0.0.10:8000 iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 8291 -j DNAT --to 10.0.0.10:8291 iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 8888 -j DNAT --to 10.0.0.10:8888
Наша группа в Viber, Наша группа в Telegram, Наша группа в ФБ, Наша группа в ВК, Мы на Youtube, maxya Тётя шура тут
«Все постоянно твердят об авторских правах, но никогда - об авторских обязанностях.» © Жан-Люк Годар

Мой телевизор: Samsung LE-32C550J1WXUA, Samsung UE55D6100, Samsung UE65°ES8007

Мой ресивер: Sat-Integral S-1248 HD Heavy Metal, VU+ Ultimo 4K

Мои спутники: 4°W+4.8°E+9°E+13°E+36°E+75°E+85°E+90°E

Информация

Посетители, находящиеся в группе Гости, не могут оставлять сообщения в данной теме.

    Вещание осуществляется в штатном режиме

    21.01.2022 c 06:42 вещание каналов от Триколора осуществляется в штатном режиме.

    Возможны перерывы в вещании каналов от Триколора

    По техническим причинам приём некоторых каналов, входящих в состав пакетов Триколора, может быть затруднен.

    Сервис «Триколор через интернет», онлайн-кинотеатр «Триколор Кино и ТВ» и услуга «Триколор Онлайн» доступны

    Доступ к услугам «Триколор через интернет», онлайн-кинотеатр «Триколор Кино и ТВ» и услуга «Триколор Онлайн» предоставляется в штатном режиме.

    Сервис «Триколор через интернет», онлайн-кинотеатр «Триколор Кино и ТВ» и услуга «Триколор Онлайн» временно недоступны.

    По техническим причинам доступ к сервису «Триколор через интернет», онлайн-кинотеатру «Триколор Кино и ТВ» и услуге «Триколор Онлайн» может быть временно затруднен.

    Вещание осуществляется в штатном режиме

    20.01.2022 г. с 13:57 вещание каналов от Триколора осуществляется в штатном режиме.

Футбол

Германия. Бундеслига, Тур 20
21 января 2022
21:30 Айнтрахт Франкфурт Айнтрахт Франкфурт -:- АрминияАрминия
Италия. Серия А, 23 тур
21 января 2022
21:45 Верона Верона -:- БолоньяБолонья
Англия. Премьер-лига, 23-й тур
21 января 2022
22:00 Уотфорд Уотфорд -:- НорвичНорвич
Франция. Лига 1, 22 тур
21 января 2022
22:00 Лион Лион -:- Сент-ЭтьенСент-Этьен
Испания. Ла Лига, 22 тур
21 января 2022
22:00 Эспаньол Эспаньол -:- БетисБетис

Обновлено: 08:10 21.01.2022

Телепрограмма

СТБ
07:55 - Т/с "Комиссар Рекс", 1 сезон, 14 с.
08:50 - Т/с "Комиссар Рекс", 2 сезон, 1 с.
09:50 - Т/с "Комиссар Рекс", 2 сезон, 2 с.
10:50 - "Слепая". "Чужие-близкие".
Футбол 1
08:00 - Топ-матч.
08:10 - Олимпия - Фламенго. Кубок Либертадорес. 1/4 финала.
10:00 - Футбол News.
10:20 - Рома - Лечче. Кубок Италии. 1/8 финала.
ICTV
07:50 - Утро в большом городе.
08:45 - Факты. Утро.
09:15 - Чрезвычайные новости.
10:10 - Дизель-шоу.
Кинопремьера HD
07:55 - Х/ф "Колумнистка".
09:20 - Х/ф "Первый клон".
11:15 - Х/ф "Восстание роботов".
12:40 - Х/ф "Девятаев".
Вся телепрограмма

Мы в Вконтакте

Мы в Facebook

Голосование

Как вы сюда попали?

yandex.ru
google.com
rambler.ru
mail.ru
мне кто-то ссылку дал!
а оно само как-то!
я блондинко,отвали....

Случайное фото

Sat-integral club

Продление G-share

Здравствуйте! Пополнил 24дол. S/N 160129012577 Продлите пожалуйста.Спасибо.

Пожелания разработчикам ПО Sat-Integral SP-1319 HD Combo / SP-1329 HD Combo

А эту модель совсем забросили или ещё будет новое ПО, или хотя бы в последнем убрать зависание ...

ПО Sat-Integral S-1218-28HD / S-1248-58-68HD / S-1311 HD COMBO v3.15/3.16

Цитата: rekord от 19 Январь 2022, 20:20:22да Извини,это был не вопрос.Я выше ему написал где искать ...

ПО Sat-Integral S-1218-28HD / S-1248-58-68HD / S-1311 HD COMBO v3.15/3.16

Цитата: Begimot от 19 Январь 2022, 20:10:33логин пароль сервер и 7777.и всё да

ПО Sat-Integral S-1218-28HD / S-1248-58-68HD / S-1311 HD COMBO v3.15/3.16

Цитата: rekord от 19 Январь 2022, 20:05:44Та не может быть,у себя в ресивере выбрать протокол ...

Киевстар списал всё

Не успели ...

Mixed Content при обращении к WebSocket

Ситуация, когда у ...